View |
Splits horizontally one region in split crop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SplitRegionHorizontally(
int regionIndex,
double leftPart,
double rightPart
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid. |
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split vertically. |

This function splits the crop into two regions: one occupying the left quarter of the crop, and the other the right quarter of the crop.