RebarConstrainedHandle Class


Rebar Constrained Handle Class

A class representing a handle on a Rebar that can be joined to a reference, such as a host Element's surface or cover, another Rebar's handle or to a generic surface.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarConstrainedHandle

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarConstrainedHandle : IDisposable

The RebarConstrainedHandle type exposes the following members.

Properties
Name Description
Public property HandleBehavior Identifies the handle behavior.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method CanSetBehavior Checks if the input behavior can be set for this RebarConstrainedHandle.
Public method Dispose Releases all resources used by the RebarConstrainedHandle
Public method GetCustomHandleTag Returns the tag of the handle. The type of the handle should be 'CustomHandle'.
Public method GetEdgeNumber If the RebarConstrainedHandle's RebarHandleType is 'Edge', then this function will return the number of the edge that is driven by the handle.
Public method GetHandleName Gets the name of the handle.
Public method GetHandleSurface Gets the surface of this handle.
Public method GetHandleType Returns the RebarHandleType of a RebarConstrainedHandle.
Public method GetPossibleHandleBehaviors Gets a list of possible handle behaviors for the current handle.
Public method IsCustomHandle Returns true if the RebarHandleType of the RebarConstrainedHandle is 'CustomHandle'.
Public method IsEdgeHandle Returns true if the RebarHandleType of the RebarConstrainedHandle is 'Edge'.
Public method IsEqual Checks if the specified RebarConstrainedHandle is the same as 'this'.
Public method IsValid Checks that the RebarConstrainedHandle still has access to valid Rebar handle data and that its RebarConstraintsManager is still valid.
Public method Move Moves the handle with the specified vector. This function applies only for shape driven rebar.
Top
Remarks

A rebar element's flexible geometry is controlled by several handles. The shape of the bar is controlled by a handle at each end of the bar and a handle each edge. Another handle is used to control the location of the plane in which the rebar lies. An additional handle controls the length of a set of rebar.

RebarConstrainedHandles can only be constructed internally by Revit. They are available to the API by querying a Rebar element's RebarConstraintsManager.

See Also