WireConduitTypeSet Class


Wire Conduit Type Set Class

A set that contains conduit types.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical WireConduitTypeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireConduitTypeSet : APIObject, 
	IEnumerable

The WireConduitTypeSet type exposes the following members.

Constructors
Name Description
Public method WireConduitTypeSet Initializes a new instance of the WireConduitTypeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of conduit types that are in the set.
Top
Methods
Name Description
Public method Clear Removes every conduit type from the set, rendering it empty.
Public method Contains Tests for the existence of a conduit type within the set.
Public method Erase Removes a specified conduit type from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified conduit type into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also