RotateRebarSpliceGeometry Method


Rebar Splice Rotate Rebar Splice Geometry Method

Rotates the RebarSpliceGeometry about the given axis and angle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RotateRebarSpliceGeometry(
	Line axis,
	double angle
)

Parameters

axis Line
The axis of rotation.
angle Double
The angle of the rotation in radians.
Exceptions
Exception Condition
ArgumentException The given value for angle is not finite
ArgumentNullException A non-optional argument was null
See Also