RemoveMainSubelementsFromCustomConnection Method


Structural Connection Handler Type Remove Main Subelements From Custom Connection Method

Removes one or more subelements from a StructuralConnectionHandlerType. The subelements will be erased.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RemoveMainSubelementsFromCustomConnection(
	StructuralConnectionHandler structuralConnectionHandler,
	IList<Subelement> subelements
)

Parameters

structuralConnectionHandler StructuralConnectionHandler
The existing StructuralConnectionHandler having custom StructuralConnectionHandlerType which is about to be modified.
subelements IList Subelement
The main Subelements of input StructuralConnectionHandler which are to be used to modify custom StructuralConnectionHandlerType.
Exceptions
Exception Condition
ArgumentException Input StructuralConnectionHandler must have custom type. -or- All the input Subelements must belong to input StructuralConnectionHandler. After modification of StructuralConnectionHandlerType there must remain at least one subelement of structural connections category in StructuralConnectionHandler.
ArgumentNullException A non-optional argument was null
See Also