Topography |
Note: This API is now obsolete.
Changes the elevation value for points
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that TopographySurface elements should be converted to Toposolid elements to enable better editing options.")]
public void ChangePointsElevation(
IList<XYZ> points,
double elevationValue
)
Parameters

Exception | Condition |
---|---|
ArgumentException | There are no points in the input points set. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for elevationValue must be no more than 30000 feet in absolute value. |
InvalidOperationException | This element is not a TopographySurface. -or- The points of this topography surface are not editable. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface. -or- None of the input points exists in the current TopographySurface. |
ModificationForbiddenException | The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document containing this TopographySurface has no open transaction. |

If none of the points in the collection doesn's exist, an exception will be thrown. This function ignores input points that do not exist, unless all of the input points do not exist, which will result in an exception. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which shoule be in an active TopographyEditScope.