Layout |
This class indicate the layout rule of a Beam System is Clear-Spacing.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleClearSpacing
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleClearSpacing
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LayoutRuleClearSpacing type exposes the following members.

Name | Description | |
---|---|---|
![]() | LayoutRuleClearSpacing | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in. |

Name | Description | |
---|---|---|
![]() | JustifyType | Get or set the type of justification. |
![]() | Spacing | Get or set the spacing of the beam system. |

Name | Description | |
---|---|---|

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
//get the layoutRule of the beamsystem
Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;
string message = "BeamSystem layout rule : " + layoutRule;
//create a new instance of the LayoutRuleClearSpacing class
LayoutRuleClearSpacing myLayoutRuleClearSpacing =
new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);
//set the new layoutRule to the beamsystem
beamSystem.LayoutRule = myLayoutRuleClearSpacing;
LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
if (null == clearSpacing)
{
return false;
}
//try to get the property value of the beamsystem LayoutRule
BeamSystemJustifyType justifyType = clearSpacing.JustifyType;
double spacing = clearSpacing.Spacing;
message += "\nNew BeamSystem layout rule: " + clearSpacing;
message += "\nNew BeamSystem spacing: " + spacing;
message += "\nNew BeamSystem justification: " + justifyType;
TaskDialog.Show("Revit",message);
return true;
}