Field |
Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetGridCoordinates(
ICollection<double> uCoordinates,
ICollection<double> vCoordinates
)
Parameters
- uCoordinates ICollection Double
- Set of u coordinates at which to draw grid lines
- vCoordinates ICollection Double
- Set of v coordinates at which to draw grid lines

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |