SetRodLength Method


Fabrication Rod Info Set Rod Length Method

Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetRodLength(
	int rodIndex,
	double newLength
)

Parameters

rodIndex Int32
The rod index.
newLength Double

Return Value

Boolean
Returns true if it was successful otherwise false.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The rod length cannot be set because the hanger is set to automatically host to other elements.
See Also