LeaderEndCondition Property


Independent Tag Leader End Condition Property

The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LeaderEndCondition LeaderEndCondition { get; set; }

Property Value

LeaderEndCondition
Exceptions
Exception Condition
ArgumentException When setting this property: LeaderEndCondition cannot be assigned.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed.
Remarks
LeaderEndCondition enumerates the supported leader end conditions. Material tags and material keynotes can only use the free end condition.
See Also