CreatePipeConnector Method (Document, PipeSystemType, Reference, Edge)


Connector Element Create Pipe Connector(Document, Pipe System Type, Reference, Edge) Method

Create a new pipe ConnectorElement with a face and an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConnectorElement CreatePipeConnector(
	Document document,
	PipeSystemType pipeSystemType,
	Reference planarFace,
	Edge edge
)

Parameters

document Document
The document to add the connector to.
pipeSystemType PipeSystemType
The PipeSystemType of the connector.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The pipe ConnectorElement.
Exceptions
Exception Condition
ArgumentException The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also