DWFXExportOptions Class


DWFXExport Options Class

DWFX Export options.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DWFXExportOptions : DWFExportOptions

The DWFXExportOptions type exposes the following members.

Constructors
Name Description
Public method DWFXExportOptions Default constructor. Sets all options to their default values.
Top
Properties
Name Description
Public property CropBoxVisible Whether to export crop box.
(Inherited from DWFExportOptions )
Public property ExportingAreas Whether to also export areas and rooms' geometry.
(Inherited from DWFExportOptions )
Public property ExportObjectData Whether to include properties associated with elements.
(Inherited from DWFExportOptions )
Public property ExportOnlyViewId Only export the specified view.
(Inherited from DWFExportOptions )
Public property ExportTexture Whether to export texture.
(Inherited from DWFExportOptions )
Public property ImageFormat Controls the compression level of images embedded.
(Inherited from DWFExportOptions )
Public property ImageQuality Image quality level when compressed raster format(JPEG) is used.
(Inherited from DWFExportOptions )
Public property MergedViews Whether to merge all views in one file.
(Inherited from DWFExportOptions )
Public property PaperFormat Standard paper format.
(Inherited from DWFExportOptions )
Public property PortraitLayout Paper orientation - Portrait/Landscape.
(Inherited from DWFExportOptions )
Public property StopOnError Whether export process should stop when a view fails to export.
(Inherited from DWFExportOptions )
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also