SaveToProjectAsImage Method


Document Save To Project As Image Method

Creates an image view from the currently active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SaveToProjectAsImage(
	ImageExportOptions options
)

Parameters

options ImageExportOptions
The options which govern the image creation.

Return Value

ElementId
Id of the newly created view if the operation succeeded, invalid element id otherwise.
Exceptions
Exception Condition
ArgumentException options object is invalid: the ExportRange is invalid, must be CurrentView or VisibleRegionOfCurrentView, or the ViewName is invalid, must be non-empty, unique and should not contain prohibited characters. -or- The current view cannot be exported as an image
ArgumentNullException A non-optional argument was null
See Also