Schedule |
Checks whether a field can be used with a substring-based filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- fieldId ScheduleFieldId
- The ID of the field to check.
Return Value
BooleanTrue if the field can be used with a substring-based filter, false otherwise.

Exception | Condition |
---|---|
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
ArgumentNullException | A non-optional argument was null |

The substring-based filter types are Contains, NotContains, BeginsWith, NonBeginsWith, EndsWith and NotEndsWith.
Only string parameters can be filtered by substring.