Wall Wall |
Retrieves or changes the type of the wall.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: The wall type wallType is not valid for the current wall. |
ArgumentNullException | When setting this property: A non-optional argument was null |

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.