GetKeyBasedTreeEntryErrors Method (KeyBasedTreeEntryErrorType)


Key Based Tree Entries Load Results Get Key Based Tree Entry Errors(Key Based Tree Entry Error Type) Method

Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors(
	KeyBasedTreeEntryErrorType type
)

Parameters

type KeyBasedTreeEntryErrorType
The type of KeyBasedTreeEntryError to be returned.

Return Value

IList KeyBasedTreeEntryError
An array of copies of the KeyBasedTreeEntryErrors contained in this object matching the type specified.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also