GetRibbonPanels Method (Tab)


UIControlled Application Get Ribbon Panels(Tab) Method

Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual List<RibbonPanel> GetRibbonPanels(
	Tab tab
)

Parameters

tab Tab
The tab on which the panels are located.

Return Value

List RibbonPanel
Remarks
Built-in panels will not be included. This method is not supported in Macros.
See Also