GetServersByType Method


External Resource Service Utils Get Servers By Type Method

Gets registered external resource servers which support the external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<IExternalResourceServer> GetServersByType(
	ExternalResourceType type
)

Parameters

type ExternalResourceType
The external resource type for the servers to match

Return Value

IList IExternalResourceServer
A list of matched external resource servers
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also