SendBackward Method (Document, View, ICollection(ElementId))


Detail Element Order Utils Send Backward(Document, View, ICollection Element Id ) Method

Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SendBackward(
	Document document,
	View view,
	ICollection<ElementId> detailElementIds
)

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to move backward.
Exceptions
Exception Condition
ArgumentException The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException A non-optional argument was null
See Also