SetFloatingRectangle Method


Dockable Pane State Set Floating Rectangle Method

When %dockPosition% is Floating, sets the rectangle used to determine the size and position of the pane when %dockPosition% is Floating. Coordinates are relative to the upper-left-hand corner of the main Revit window.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFloatingRectangle(
	Rectangle rect
)

Parameters

rect Rectangle
The rectangle to use when floating.
Exceptions
Exception Condition
ArgumentException Rectangle is not normalized.
ArgumentNullException A non-optional argument was null
See Also