Central |
The base class for exceptions that are common to both file-based and server-based central models or specific to just file-based central models.

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions CentralModelException
More
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions CentralModelException
More
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CentralModelException type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException GetObjectData(SerializationInfo, StreamingContext) ) |

Reference

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions CentralModelException
Autodesk.Revit.Exceptions CentralFileCommunicationException
Autodesk.Revit.Exceptions CentralModelAccessDeniedException
Autodesk.Revit.Exceptions CentralModelAlreadyExistsException
Autodesk.Revit.Exceptions CentralModelContentionException
Autodesk.Revit.Exceptions CentralModelVersionArchivedException
Autodesk.Revit.Exceptions CheckoutElementsRequestTooLargeException
Autodesk.Revit.Exceptions OutdatedDirectlyOpenedCentralException
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions CentralModelException
Autodesk.Revit.Exceptions CentralFileCommunicationException
Autodesk.Revit.Exceptions CentralModelAccessDeniedException
Autodesk.Revit.Exceptions CentralModelAlreadyExistsException
Autodesk.Revit.Exceptions CentralModelContentionException
Autodesk.Revit.Exceptions CentralModelVersionArchivedException
Autodesk.Revit.Exceptions CheckoutElementsRequestTooLargeException
Autodesk.Revit.Exceptions OutdatedDirectlyOpenedCentralException