Curve Get |
Returns the raw parameter value at the start or end of this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- index Int32
- 0 for the start or 1 for end of the curve.
Return Value
DoubleThe parameter.

Exception | Condition |
---|---|
ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end. |
ArgumentNullException | A non-optional argument was NULL |

The start and end value of the parameter can be any value (as it is determined by the system based on the inputs). For curves with regular curvature like lines and arcs, the raw parameter can be used to measure along the curve in Revit's default units (feet). Raw parameters are also the only way to evaluate points along unbound curves.