AddAssociation Method (ISet(ElementId), ISet(ElementId))


Analytical To Physical Association Manager Add Association(ISet Element Id , ISet Element Id ) Method

Adds a new association between a group of analytical elements and a group of physical elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddAssociation(
	ISet<ElementId> analyticalElementIds,
	ISet<ElementId> physicalElementIds
)

Parameters

analyticalElementIds ISet ElementId
Ids of the analytical elements.
physicalElementIds ISet ElementId
Ids of the physical elements.
Exceptions
Exception Condition
ArgumentException Analytical id is not valid or has already defined another association. -or- Physical id is not valid or has already defined another association.
ArgumentNullException A non-optional argument was null
Remarks
The arguments must be ids of analytical and of physical elements that don't have other associations, otherwise an exception is thrown. Physical elements can have one of these categories:
  • Columns
  • Curtain Wall Panels
  • Floors
  • Generic Models
  • Mass
  • Parts
  • Railings
  • Ramps
  • Roofs
  • Stairs
  • Structural Columns
  • Structural Foundation
  • Structural Framing
  • Structural Trusses
  • Structural Beam System
  • Walls
Analytical elements can have one of these categories:
  • Analytical Member
  • Analytical Panel
See Also