AreaBasedLoadData Class


Area Based Load Data Class

Represents the electrical area based load data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical ZoneElementDomainData
Autodesk.Revit.DB.Electrical AreaBasedLoadData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaBasedLoadData : ZoneElementDomainData

The AreaBasedLoadData type exposes the following members.

Properties
Name Description
Public property ApparentLoad The electrical apparent load of the area based load.
Public property ApparentPowerDensity The apparent power density of the area based load.
Public property AreaBasedLoadType The electrical area based load type of the area based load.
Public property ConnectedPhases The electrical connected phases of the area based load to its upstream node.
Public property Current The current of the area based load .
Public property LoadClassification The load classification of the area based load.
Public property LoadDensity The load density of the area based load.
Public property LoadType The load type of the area based load.
Public property PhasesNumber The number of electrical phases of the area based load.
Public property PowerFactor The power factor of the area based load.
Public property PowerFactorState The power factor state of the area based load.
Public property TrueLoad The electrical true load of the area based load.
Public property Voltage The voltage of the area based load.
Top
Methods
Name Description
Public method AddElectricalLoadArea Adds electrical load area into the area based load.
Public method CanConnectToUpstreamNode Verifies that the area based load can connect to the upstream electrical analytical node. If the area based load already has an upstream node or the upstream node is full of downstream nodes, the area based load can't connect to the upstream node.
Public method CanDisconnectFromUpstreamNode Verifies that the area based load can disconnect from the upstream electrical analytical node. If the area based load hasn't an upstream node, it can't disconnect from the upstream node.
Public method ConnectToUpstreamNode Connects to an upstream electrical analytical node.
Public method DisconnectFromUpstreamNode Disconnects from an upstream electrical analytical node.
Public method GetElectricalLoadAreas Gets electrical load areas which the area based load includes.
Public method GetUpstreamNodeId Gets the upstream electrical analytical node id.
Public method RemoveElectricalLoadArea Removes electrical load area from the area based load.
Top
See Also