GetBoxCenter Method


Viewport Get Box Center Method

Returns the center of the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetBoxCenter()

Return Value

XYZ
The center of the outline of the viewport on the sheet.
Exceptions
Exception Condition
InvalidOperationException The viewport is not on a sheet.
See Also