AddVertex Method


Vertex Stream Position Colored Add Vertex Method

Inserts a VertexStreamPositionColored into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddVertex(
	VertexPositionColored vertex
)

Parameters

vertex VertexPositionColored
The vertex to be inserted.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.
See Also