PipePlumbingFixtureFlowData Class


Pipe Plumbing Fixture Flow Data Class

The input and output data used by external servers for calculation of the pipe plumbing fixture flow.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Plumbing PipePlumbingFixtureFlowData

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PipePlumbingFixtureFlowData : IDisposable

The PipePlumbingFixtureFlowData type exposes the following members.

Properties
Name Description
Public property DimensionFlow The dimension flow which is used to calculate flow of the pipe. Units: (gal/min).
Public property FixtureUnits The fixture units of the pipe.
Public property Flow The actual flow of the plumbing fixture converted from dimension flow or fixture unit. Units: (gal/min).
Public property FlowConfiguration The flow configuration mode of the pipe.
Public property FlowConversionMode The flow conversion mode of the pipe.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PipePlumbingFixtureFlowData
Top
Remarks
FlowConfiguration, FixtureUnits, FlowConversionMode, and DimensionFlow are input field values for the calculation. Flow is output field value for the calculation.
See Also