RebarShapeConstraintAngleFromFixedDir Class


Rebar Shape Constraint Angle From Fixed Dir Class

A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintAngleFromFixedDir

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintAngleFromFixedDir : RebarShapeConstraint

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintAngleFromFixedDir Create an angular constraint.
Top
Properties
Name Description
Public property Direction A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property Sign When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.
Top
Methods
Name Description
Top
See Also