RebarShapeConstraintAngleFromFixedDir Class


Rebar Shape Constraint Angle From Fixed Dir Class

A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintAngleFromFixedDir

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintAngleFromFixedDir : RebarShapeConstraint

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintAngleFromFixedDir Create an angular constraint.
Top
Properties
Name Description
Public property Direction A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint )
Public property Sign When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.
Top
Methods
Name Description
Public method Dispose
(Inherited from RebarShapeConstraint )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also