GetCustomDistributionPath Method


Rebar Free Form Accessor Get Custom Distribution Path Method

Gets the custom distribution path for free form rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Curve> GetCustomDistributionPath()

Return Value

IList Curve
Returns an array of curves that represent the distribution path.
Exceptions
Exception Condition
InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference. -or- This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID.
Remarks
For a free form rebar set the distance between two consecutive bars may be different if it is calculated between different points on bars. The distribution path is an array of curves with the property that based on these curves the set was calculated to respect the layout rule and number of bars or spacing.
See Also