Application Get |
Gets the worksharing central GUID of the given server-based model.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- serverModelPath ServerPath
- The server-based model path.
Return Value
GuidThe worksharing central GUID.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator. |
InapplicableDataException | Thrown when the given model is not created in Revit 2013 or later release. |
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |
RevitServerInternalException | An internal error happened on the server, please contact the server administrator. |

The given server-based model saved in a release prior to Revit 2013 did not have this GUID. Only the given server-based model saved in Revit 2013 or later will be able to provide this value.