CreateUnbound Method


Line Create Unbound Method

Creates a new instance of an unbound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Line CreateUnbound(
	XYZ origin,
	XYZ direction
)

Parameters

origin XYZ
The origin of the unbound line.
direction XYZ
The direction of the unbound line.

Return Value

Line
The new unbound line.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
ArgumentOutOfRangeException direction has zero length.
ArgumentsInconsistentException Vector and origin cannot form a proper unbound line.
Example
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateUnbound(startPoint, directionPt);
See Also