RevitAPIPreEventArgs Class


Revit APIPre Event Args Class

The class is used as a base class for the arguments for any pre-event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitAPIPreEventArgs : RevitAPIEventArgs

The RevitAPIPreEventArgs type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method Cancel When the event is cancellable, may call the Cancel() method to cancel it.
Top
Remarks
A pre-event is the event raised before executing the process that was related with the event.
See Also
Inheritance Hierarchy