SetNonControlledTemplateParameterIds Method


View Set Non Controlled Template Parameter Ids Method

Sets the parameters that will not be included when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetNonControlledTemplateParameterIds(
	ICollection<ElementId> newSet
)

Parameters

newSet ICollection ElementId
The parameter ids that should not be marked to be included.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This should be a subset of the parameters returned by GetTemplateParameterIds (other parameters will be ignored).
See Also