GetSectionBox Method


View 3D Get Section Box Method

Gets a copy of the section box for this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxXYZ GetSectionBox()

Return Value

BoundingBoxXYZ
The section box. Note that the section box can be rotated and transformed and thus you will need to use [!:Autodesk::Revit::DB::BoundingBoxXYZ::Transform] to interpret the coordinates of the corners or sides of the box in model coordinates.
Exceptions
Exception Condition
InvalidOperationException Returns true if the view is not a view template.
Remarks
The section box cuts the model in this view by its boundaries.
See Also