Element |
A base class for all types of binding that attach to an element.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Autodesk.Revit.DB TypeBinding
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Autodesk.Revit.DB TypeBinding
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementBinding type exposes the following members.

Name | Description | |
---|---|---|
![]() | Categories | Retrieve or set the categories to which a parameter definition will be bound. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This base class provides methods that are common to all types of binding that work with elements.