GetSegmentLength Method


MEPSection Get Segment Length Method

Get the length for the specified segment id in this section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetSegmentLength(
	ElementId segmentId
)

Parameters

segmentId ElementId
The element id which can be duct segment and pipe segment.

Return Value

Double
Exceptions
Exception Condition
ArgumentException The ElementId segmentId does not correspond to a valid section segment member.
ArgumentNullException A non-optional argument was null
See Also