FilteredElementCollector Methods


Filtered Element Collector Methods

The FilteredElementCollector type exposes the following members.

Methods
Name Description
Public method ContainedInDesignOption Applies an ElementDesignOptionFilter to the collector.
Public method Dispose
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Excluding Applies an ExclusionFilter to the collector.
Public method Code example FirstElement Returns the first element to pass the filter(s).
Public method Code example FirstElementId Returns the id of the first element to pass the filter(s).
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetElementCount Gets the number of elements in your current filter.
Public method Code example GetElementIdIterator Returns an element id iterator to the elements passing the filters.
Public method Code example GetElementIterator Returns an element iterator to the elements passing the filters.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IntersectWith Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method Static member IsViewValidForElementIteration Identifies if the particular element is valid for iteration of drawn elements.
Public method Code example OfCategory Applies an ElementCategoryFilter to the collector.
Public method OfCategoryId Applies an ElementCategoryFilter to the collector.
Public method Code example OfClass Applies an ElementClassFilter to the collector.
Public method OwnedByView Applies an ElementOwnerViewFilter to the collector.
Public method ToElementIds Returns the complete set of element ids that pass the filter(s).
Public method ToElements Returns the complete set of elements that pass the filter(s).
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method UnionWith Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method WhereElementIsCurveDriven Applies an ElementIsCurveDrivenFilter to the collector.
Public method WhereElementIsElementType Applies an ElementIsElementTypeFilter to the collector.
Public method WhereElementIsNotElementType Applies an inverted ElementIsElementTypeFilter to the collector.
Public method WhereElementIsViewIndependent Applies an ElementOwnerViewFilter to the collector.
Public method WherePasses Applies an element filter to the collector.
Top
See Also