SetMapForFamilySymbolToFabricationPartType Method


Design To Fabrication Converter Set Map For Family Symbol To Fabrication Part Type Method

Set a map for the conversion of in line family symbols to similar fabrication part types.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DesignToFabricationMappingResult SetMapForFamilySymbolToFabricationPartType(
	IDictionary<ElementId, ElementId> typeMappings
)

Parameters

typeMappings IDictionary ElementId , ElementId
The map containing the family symbol element identifiers to the fabrication part type element identifiers to convert to.

Return Value

DesignToFabricationMappingResult
If the mapping is properly structured, DesignToFabricationMappingResult.Success is returned. Otherwise, consult the members of DesignToFabricationMappingResult to understand why this call failed.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also