Project |
Generate a copy of this project location with the specified name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- name String
Return Value
ProjectLocationA new ProjectLocation which is a duplicate of this location, with the input name.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The name must not be the same as the name of any existing locations. This function will modify the document, as the new ProjectLocation will be added to it.

public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
ProjectLocation currentLocation = document.ActiveProjectLocation;
ProjectLocationSet locations = document.ProjectLocations;
foreach (ProjectLocation projectLocation in locations)
{
if (projectLocation.Name == newName)
{
throw new Exception("The name is same as a project location's name, please change one.");
}
}
return currentLocation.Duplicate(newName);
}