Path |
The RebarShape element that defines the shape of the alternating bars of the Path Reinforcement.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: shapeId should refer to two dimensional Rebar Shape element with segments forming only right angles. |
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | When setting this property: This Path Reinforcement does not have alternating bars enabled. -or- When setting this property: This PathReinforcement does not host Rebar. |

Changing the value of this property causes the Path Reinforcement to choose values for its shape parameters. Before calling this method, alternating bars have to be enabled in the Path Reinforcement by setting PATH_REIN_ALTERNATING BuiltInParameter.