SetSurfaceForegroundPatternId Method


Override Graphic Settings Set Surface Foreground Pattern Id Method

Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public OverrideGraphicSettings SetSurfaceForegroundPatternId(
	ElementId fillPatternId
)

Parameters

fillPatternId ElementId
Value of the surface foreground fill pattern override.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also