EvaluateParameterValues Method


Element Evaluate Parameter Values Method

Evaluate the parameters' values of the element on the given parameter ID set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<EvaluatedParameter> EvaluateParameterValues(
	ISet<ElementId> parameterIds
)

Parameters

parameterIds ISet ElementId
Parameter IDs with which the ParameterValue to be retrieved.

Return Value

IList EvaluatedParameter
List of EvaluatedParameter of the element, which does not include those that cannot be retrieved but are passed in through parameterIds .
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also