Export Method (String, String, NavisworksExportOptions)


Document Export(String, String, Navisworks Export Options) Method

Exports a Revit project to the Navisworks .nwc format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Export(
	string folder,
	string name,
	NavisworksExportOptions options
)

Parameters

folder String
The name of the folder for the exported file.
name String
The name of the exported file. If it doesn't end in '.nwc', this extension will be added automatically.
options NavisworksExportOptions
Options which control the contents of the export.
Exceptions
Exception Condition
ArgumentException NullOrEmpty -or- Contains invalid characters. -or- The input options were not valid. Check the exception message for specific details.
ArgumentNullException A non-optional argument was null
InvalidOperationException Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException The folder does not exist.
OperationCanceledException The export operation is cancelled in event handler.
OptionalFunctionalityNotAvailableException A Navisworks Exporter is not available in the installed Revit.
Remarks
This is an optional functionality that does not have to be installed. The method "OptionalFunctionalityUtils.isNavisworksExporterAvailable()" can be called to check if the exporter is present.
See Also