SetCellText Method


Table Section Data Set Cell Text Method

Sets a cell's to display the specified text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCellText(
	int nRow,
	int nCol,
	string text
)

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.
text String
The text to show in the cell.
Exceptions
Exception Condition
ArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation is forbidden for cells in standard schedule body sections.
Remarks
If this cell's type is not CellType.Text, and the operation is permitted on this cell, the cell type will be changed to type CellType.Text as a result of this call.
See Also