FamilyManager Class


Family Manager Class

The family manager object to manage the family types and parameters in family document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyManager : APIObject

The FamilyManager type exposes the following members.

Properties
Name Description
Public property CurrentType The current family type.
Public property Parameter BuiltInParameter Obtains the parameter of this type with a given parameter id.
Public property Parameter Definition Obtains the parameter of this type with a given definition.
Public property Parameter Guid Obtains the parameter of this type with a given GUID for a shared parameter.
Public property Parameter String Obtains the parameter of this type with a given name.
Public property Parameters All family parameters in this family.
Public property Code example Types All family types in the family.
Top
Methods
Name Description
Public method AddParameter(ExternalDefinition, ForgeTypeId, Boolean) Add a new shared parameter to the family.
Public method AddParameter(String, ForgeTypeId, Category, Boolean) Add a new family type parameter to control the type of a nested family within another family.
Public method AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) Add a new family parameter with a given name.
Public method AssociateElementParameterToFamilyParameter Associates or disassociates the element parameter to an existing family parameter.
Public method CanElementParameterBeAssociated Indicates if this element parameter can be associated with a family parameter.
Public method DeleteCurrentType Remove the current family type.
Public method GetAssociatedFamilyParameter Gets the associated family parameter of an element parameter.
Public method GetParameter Obtains the family parameter with the given built-in parameter identifier.
Public method GetParameters Gets the parameters associated to family types in order.
Public method IsParameterLockable For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method IsParameterLocked For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method IsUserAssignableParameterGroup Checks if the given parameter group can be assigned to new parameters.
Public method MakeInstance Set the family parameter as an instance parameter.
Public method MakeNonReporting Set the reporting family parameter as a regular/driving parameter.
Public method MakeReporting Set the family parameter as a reporting parameter.
Public method MakeType Set the family parameter as a type parameter.
Public method Code example NewType Add a new family type with a given name and makes it be the current type.
Public method RemoveParameter Remove an existing family parameter from the family.
Public method RenameCurrentType Rename the current family type.
Public method RenameParameter Rename a family parameter.
Public method ReorderParameters Reorders the family parameters by the specified parameters order.
Public method ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) Replace a family parameter with a shared parameter.
Public method ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) Replace a shared family parameter with a new non-shared family parameter.
Public method Set(FamilyParameter, ElementId) Set the ElementId value of a family parameter of the current family type.
Public method Set(FamilyParameter, Double) Set the double value of a family parameter of the current family type.
Public method Set(FamilyParameter, Int32) Set the integer value of a family parameter of the current family type.
Public method Set(FamilyParameter, String) Set the string value of a family parameter of the current family type.
Public method SetDescription Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method SetFormula Set the formula of a family parameter.
Public method SetParameterLocked For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method SetValueString Set the string value of a family parameter of the current family type.
Public method Code example SortParameters Sorts the family parameters according to the desired sort order.
Top
See Also