ExternalDefinitionCreationOptions Class


External Definition Creation Options Class

An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalDefinitionCreationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalDefinitionCreationOptions : IDisposable

The ExternalDefinitionCreationOptions type exposes the following members.

Constructors
Name Description
Public method ExternalDefinitionCreationOptions Constructs the options using a specified name and type.
Top
Properties
Name Description
Public property Description The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property GUID The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property HideWhenNoValue This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of the parameter definition to be created.
Public property UserModifiable This property indicates whether this parameter can be modified by UI user or not.
Public property Visible True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalDefinitionCreationOptions
Public method GetDataType Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public method SetDataType Sets the parameter's data type.
Top
See Also