Create Method (Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult)


Import Instance Create(Document, View, External Resource Reference, OBJImport Options, Link Load Result ) Method

Creates a new instance of OBJ link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ImportInstance Create(
	Document document,
	View DBView,
	ExternalResourceReference resourceReference,
	OBJImportOptions options,
	out LinkLoadResult linkLoadResult
)

Parameters

document Document
The document in which to create the OBJ link.
DBView View
The view into which the OBJ link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the OBJ link.
options OBJImportOptions
Various import options applicable to the OBJ format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the OBJ link. It contains the ElementId of the new created OBJ link type.

Return Value

ImportInstance
The new instance of OBJ link type created.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
OptionalFunctionalityNotAvailableException The OBJ Import/Link module is not available in the installed Revit.
Remarks

This function creates a new OBJ link type as well as a new instance of this OBJ link type. The new instance of OBJ link type is returned by this function and the element id of the new OBJ link type is contained in the LinkLoadResult.

If the given external resource reference of the OBJ link is already used by an existing OBJ link type, a new instance of this existing OBJ link type is created and returned. The element id of the existing OBJ link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also