SetCalculatedDimensionValue Method


Fabrication Part Set Calculated Dimension Value Method

Sets the calculated dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCalculatedDimensionValue(
	FabricationDimensionDefinition dim,
	string value
)

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.
value String
The calculated dimension value.
Exceptions
Exception Condition
ArgumentException value is not a valid calculated fabrication dimension value. -or- fabrication dimension is unable to be modified because it is locked or from a product list. -or- the fabrication dimension is unable to be modified because it will affect the geometry of a connected end.
ArgumentNullException A non-optional argument was null
InvalidOperationException the fabrication dimension is unable to be modified because the fabrication part is connected to more than one object. -or- the fabrication dimension cannot be set to the option: value.
Remarks
Multiple dimensions may need to be set in order to reach the desired outcome. The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also