Compound |
Gets the segment ids of this compound structure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
IList Int32The ids of the segments which form the boundary of the regions of this CompoundStructure.

Exception | Condition |
---|---|
InvalidOperationException | This operation is valid only for vertically compound structures. |

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids.