IFrameworkElementCreator Interface


IFramework Element Creator Interface

Interface that the Revit UI will call, if present, to construct the FrameworkElement for the pane.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IFrameworkElementCreator

The IFrameworkElementCreator type exposes the following members.

Methods
Name Description
Public method CreateFrameworkElement Method called to create the FrameworkElement.
Top
Example
// 
// Class implementing the interface used in Revit to 
// on demand create the pane UI.
// 
internal class BrowserCreator : IFrameworkElementCreator
{
   // 
   // Implement the creation call back by returning a
   // new WebBrowser each time the callback is triggered. 
   // 
   public FrameworkElement CreateFrameworkElement()
   {
      return new WebBrowser();
   }
}
See Also